博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1058 hdoj 1058
阅读量:4123 次
发布时间:2019-05-25

本文共 1972 字,大约阅读时间需要 6 分钟。

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7320    Accepted Submission(s): 3183
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence
 
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 
Sample Input
1234111213212223100100058420
 
Sample Output
The 1st humble number is 1.The 2nd humble number is 2.The 3rd humble number is 3.The 4th humble number is 4.The 11th humble number is 12.The 12th humble number is 14.The 13th humble number is 15.The 21st humble number is 28.The 22nd humble number is 30.The 23rd humble number is 32.The 100th humble number is 450.The 1000th humble number is 385875.The 5842nd humble number is 2000000000.

#include <stdio.h>
int f[5843],n;
int i,j,k,t,l;
int min(int a,int b,int c,int d);
int main()
{
    i=1,j=1,k=1,l=1;
    f[1]=1;
    for(t=2;t<=5842;t++)
    {
        f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);
    }
    while(scanf("%d",&n)&&n!=0)
    {
        if(n%10==1&&n%100!=11)
            printf("The %dst humble number is %d.\n",n,f[n]);
        else if(n%10==2&&n%100!=12)
            printf("The %dnd humble number is %d.\n",n,f[n]);
        else if(n%10==3&&n%100!=13)
            printf("The %drd humble number is %d.\n",n,f[n]);
        else
            printf("The %dth humble number is %d.\n",n,f[n]);
    }   
    return 1;
}
int min(int a,int b,int c,int d)
{
    int min=a;
    if(b<min) min=b;
    if(c<min) min=c;
    if(d<min) min=d;
    if(a==min) i++;
    if(b==min) j++;
    if(c==min) k++;
    if(d==min) l++;
    return min;
}

转载地址:http://uttpi.baihongyu.com/

你可能感兴趣的文章
菜单树
查看>>
设计模式六大原则(6):开闭原则
查看>>
阿里面试总结--JAVA
查看>>
Servlet的生命周期
查看>>
JAVA八大经典书籍,你看过几本?
查看>>
《读书笔记》—–书单推荐
查看>>
【设计模式】—-(2)工厂方法模式(创建型)
查看>>
有return的情况下try catch finally的执行顺序(最有说服力的总结)
查看>>
String s1 = new String("abc"); String s2 = ("abc");
查看>>
JAVA数据类型
查看>>
Xshell 4 入门
查看>>
SoapUI-入门
查看>>
Oracle -常用命令
查看>>
JAVA技术简称
查看>>
ORACLE模糊查询优化浅谈
查看>>
2017——新的开始,加油!
查看>>
【Python】学习笔记——-6.2、使用第三方模块
查看>>
【Python】学习笔记——-7.0、面向对象编程
查看>>
【Python】学习笔记——-7.2、访问限制
查看>>
【Python】学习笔记——-7.3、继承和多态
查看>>